What MS Outlook versions are supported for the Outlook Plugin?

The Outlook Plugin allows users to conduct searches directly from the email client and is supported for Outlook 2010 (32 and 64-bit versions) and higher.

Have more questions? Submit a request

Comments

Powered by Zendesk